Degraded connectivity for some Lightfoot devices

Incident Report for Lightfoot

Resolved

Normal operation has been confirmed. This issue will be marked as closed but we will continue to monitor this closely whilst working with our third-party network provider to understand the root cause.
Posted Sep 07, 2026 - 10:36 BST

Monitoring

Device data was flowing normally again over the weekend but we have had no official update from our third-party provider that this incident is resolved from their end. We are continuing to investigate.
Posted Sep 07, 2026 - 09:19 BST

Investigating

We are observing an increase in signal loss events for some devices, caused by an intermittent connectivity issue in the cellular network layer. This is being investigated by our mobile network operators.

As a result, some vehicle locations and statuses may be temporarily delayed via the Fleet Management portal and other interfaces. Lightfoot devices will retain their data and transmit this to our servers as soon as possible and no data will be lost.

We apologise for any inconvenience caused.
Posted Sep 04, 2026 - 13:00 BST
This incident affected: Fleet Management Portal (my.lightfoot.co.uk) and Fleet Management API (data.lightfoot.co.uk).