Incorrectly Flagged Van Overspeeds

Incident Report for Lightfoot

Resolved

Following changes to our overspeed processing, we have seen a significant reduction in incorrectly flagged van overspeeds.
Posted Sep 11, 2026 - 14:59 BST

Monitoring

We have identified that the issue is being caused by bad data being returned from a third party. In order to mitigate the issue we have deployed a temporary fix to our Overspeed processing whilst they investigate the issue.
Posted Sep 09, 2026 - 08:21 BST

Investigating

Some roads with a 60 mph limit are showing incorrect speed limits for vans. This is causing vans to be incorrectly flagged as speeding.
Posted Sep 08, 2026 - 15:49 BST
This incident affected: Fleet Management Portal (my.lightfoot.co.uk), Fleet Management API (data.lightfoot.co.uk), and Driver Mobile App.